ID #1160

Tiff Export - I want to export a high res image from Enfold, but the tiff looks bitmapped no matter what I do.

Tiff image export (accessed from the Export command from the Enfold 3D View palette menu) has a limit of 1024 x 1024 pixels on the size of the "image map" wrapped around the 3D object. The reason for the limit has to do with the internal data structure and the U3D file format.

For now this limit can only be overcome by exporting the actual 3D file and increasing the resolution of the image map (as outlined below). This improved 3D file can then be used to create a new presentation image, animation or Live 3D presentation.

Creating High Resolution Presentation Images with Photoshop CS4 or CS5 Extended

Open the U3D file in Photoshop CS4 Extended or CS5 Extended (only the Extended versions support 3D layers). In the Layers panel of Photoshop you'll see your 3D object along with a list of textures applied to the surface. The one you'll want to double-click on to open will have the name "texture1_0". Once you double click on this texture name a new Photoshop document will open displaying the texture map.

Now increase the resolution of this texture map by going to the Image menu and selecting Image Size. Increase the resolution of the image to a size you feel will support the renderings you intend to create (often increasing the size to 200% is sufficient). You now have a high resolution but blurry texture map. We'll now we fix the blurry issue.

Open your original design in Illustrator. Hide everything except the art you want applied to the folded project and choose "All" from the "Select" menu - then copy that selected art. Now go back to Photoshop and paste the art into the Ps texture map document. If you want to be able to edit the art and retain the ability to size it up later to even higher resolution choose "Smart Object" from the dialog asking you how you want to paste it in - otherwise choose "Pixels".

When you paste the art in you are automatically put into Transform mode for the art. Now scale the art to match the fuzzy placeholder art underneath.

After you scale the art and hit the Return (or Enter) key you may need to add a layer underneath the hi-res art to cover the previous fuzzy art. Now just close the texture1_0 document. You'll be asked if you want to save - say Yes. Now when you look at your 3D layer in Photoshop the object will display this higher resolution map.

Note: You may see some problems when viewing your 3D object in Photoshop that will look like white dots or triangles showing up across the surface. The cause of this can be attributed to the fact that Enfold 3D exports and "inside" mesh (which is white) and an "outside" mesh (which has the texture map applied to it).

You can hide the inside mesh using Photoshop's 3D panel. You can access this from the Window menu. In the 3D panel choose the left-most to button to set the palette's contents to Scene. You'll see a list containing two objects with names that start with "ModelResource". Hide the second object with that name in the list. You'll note the white inside mesh will disappear and the problems will go away.

Creating High Resolution Presentation Images with Strata Design 3D CX 6 or 7

Open the U3D file in Strata Design 3D 6 or 7. Locate the texture for your Enfold model file and open it (textures can be found using the Texture tab of the Resource palette).

In the "Image Texture" dialog, click on the thumbnail for the Diffuse Color map to open the Image Map dialog. From the View Scale pop-up menu select 100% (the view scale effects the resolution that the map gets copied at onto the clipboard). Now copy that image. Go to Photoshop and create a new document. Paste the color map into the new document (you'll notice that the image is squished and has a black boarder on one side. This is compensated for in the UV mapping of the mesh).

Now go to the Image menu and select Image Size. Increase the resolution of the image to a size you feel will support the renderings you intend to create (often increasing the size to 200% is sufficient). You now have a high resolution but blurry texture map. We'll now we fix the blurry issue.

Open your original design in Illustrator. Hide everything except the art you want applied to the folded project and choose "All" from the "Select" menu - then copy that selected art. Now go back to Photoshop and paste the art into the Ps document your created earlier.

If you want to be able to edit the art and retain the ability to size it up later to even higher resolution choose "Smart Object" from the dialog asking you how you want to paste it in - otherwise choose "Pixels".

When you paste the art in you are automatically put into Transform mode for the art. Now scale the art to match the fuzzy placeholder art underneath. After you scale the art and hit the Return (or Enter) key you may need to add a layer underneath the hi-res art to cover the previous fuzzy art.

Now choose Select All and then use the Copy Merged command from the Edit menu. Go back to Design 3D to paste this higher res map back into your Image Map dialog for the Diffuse Color channel of your texture. Alternatively, you can save the Photoshop document and use it for a source to link to the surface of your Design 3D model via the texture linking feature. Linking will allow you to res-up the Photoshop document if need be in the future. This works particularly well if you choose to paste the Illustrator artwork into your Photoshop document as a "Smart Object".

Tags: -

Related entries:

You cannot comment on this entry